LACP

Fra wiki.iptables.dk
Skift til: navigering, søgning

LACP står for "Link Aggregation Control Protocol". Det er en standart for hvordan flere forbindelser mellem to netværks-enheder kan bindes sammen til en. Cisco bruger navnet "port channel", hvor andre bruger "trunk". I Cisco-verden betyder "trunk" et link hvor flere VLANs køre over.

Cisco setup

IOS

Konfiguation

interface range GigabitEthernet1/0/3 , GigabitEthernet2/0/3
 channel-group 3 mode active

interface Port-channel3
  !! Normal interface konfig laves herefter
  switchport access vlan 666
  spanning-tree portfast

Debugging

show etherchannel 3 summary

NX-OS

Konfiguation

interface Ethernet101/1/77 Ethernet102/1/77
  channel-group 9999 mode active

interface port-channel9999
  !! Normal interface konfig laves herefter
  switchport access vlan 666
  spanning-tree port type edge

Debugging

show port-channel summary interface port-channel 9999

Linux setup

Debian/Ubuntu

Installer pakken ifenslave

apt-get install ifenslave

Rediger /etc/network/interfaces

auto bond0
iface bond0 inet static
        bond-mode 4
        bond-miimon 100
        bond-slaves eth0 eth1
        bond-xmit-hash-policy 1
        bond-lacp-rate 1
        ## Normal interface konfiguration laves herefter
        address 1.2.3.4
        netmask 255.255.255.0
        gateway 1.2.3.1

Alternativ /etc/network/interfaces

auto bond0
iface bond0 inet static
        bond-mode 4
        bond-miimon 100
        bond-slaves none
        bond-xmit-hash-policy 1
        bond-lacp-rate 1
        #Normal interface konfiguration indsættes herefter
        address 1.2.3.4
        netmask 255.255.255.0
        gateway 1.2.3.1

auto eth0
iface eth0 inet manual
        bond-master bond0
        bond-primary eth0 eth1

auto eth1
iface eth1 inet manual
        bond-master bond0
        bond-primary eth0 eth1

Debugging

cat /proc/net/bonding/bond0